OctoPrintのバージョンアップ通知が現れたんでいつも通りアップデートしたらハマりました。

#いつも通りのアップデート
cd ~/OctoPrint/
git pull
./venv/bin/python setup.py clean
./venv/bin/python setup.py install

症状はアップデート中エラーで中断してしまいます。
問題はpipのsslがどうやらこうやらというもの。
原因はRaspberry PiのOS(Raspbian Wheezy)が対応しないらしいです。
かなり時間かけて調べたんですけどWheezyにこだわることがセキュリティ的にも良くないようなのでOSの入れ替えを決行します。
で、入れ替え中の様子。

なんでいつも唐突なんでしょうかね。