WordPressのバックアップは、Windowsマシン + vccw で処理してます。

いつもと同じようにwordmoveを走らせたらdatabaseのところで下記のエラーが出ました。

/home/vagrant/.gem/ruby/2.3.0/gems/wordmove-2.0.0/lib/wordmove/sql_adapter.rb:44:in `gsub!’: invalid byte sequence in UTF-8 (ArgumentError)

全く見当が付かないので、この長いエラー文字列をそのままコピペして検索。

かろうじて3件だけヒットした中のひとつがビンゴです。

invalid byte sequence in UTF 8 while pushing pulling db

このページに

What should I do?

Use --hex-blob mysqldump’s flag (recommended)

って書いてあるので何も考えずに、Movefileを編集します。
databese: の mysqldump_options: に –hex-blob を追加。

mysqldump_options: "--hex-blob"

編集後、
wordmove pull -d
を実行したらエラー無く終了しました。
念のためにバックアップしたサイトを閲覧してみましたがヘンなところは見つからなかったのできっと大丈夫でしょう。^^